Data Processing Delays - Atrilyx & Custom Reports - Facebook - April 13th data

Incident Report for Atrilyx

Resolved

Facebook data has fully synced on the Atrilyx dashboard. The data will be refreshed for custom reports shortly.
Posted Apr 14, 2026 - 10:54 EDT

Investigating

our network data provider is currently experiencing delays with the Facebook network data for April 13th. Once the data becomes available, we will process it into Atrilyx and the custom reports.
Posted Apr 14, 2026 - 09:13 EDT
This incident affected: Ad Network APIs, Custom Reports, and Atrilyx.